With this lab session we will learn how to program a pick and place operation inside the RobotStudio simulated environment.

In particular we will learn how to:

- Import an external user-defined geometry (.stl file) inside the station
- Activate some robot functionalities according to the state of I/O signals
- Allow the robot to pick an object and place it in a desired location
- Compute the cycle-time related to the execution of a certain robot activity

How to proceed
1. Open RobotStudio and create a new solution with an empty station.
2. From the “Home” tab, select the button “ABB Library” to import the robot ABB IRB140.
3. From the “Home” tab, select the button “Virtual Controller/From Layout” and import the robot controller RobotWare 6.09.
4. From the “Home” tab, select the button “Import Library/Equipment” and import the tool “ABB Smart Gripper” in the Layout browser.
5. From the “Layout” browser, drag “Smart_Gripper_Servo_Fingers” and drop it to the component “IRB140_6_81_C_03”, to attach the tool to the robot end effector.
6. From the Home tab under the “Import Library” Menu, select “Equipment/Training objects” library and choose the “propeller table”.
7. Select the table in the Layout browser and then, in the menu Modify, choose the button “Set Position” to set its position XYZ as (400, −200, 0) in mm in the World frame.
8. From the Home tab under the “Import Geometry” Menu, select “Browse for geometry” and choose “Cube.stl”.
9. Select the Cube and activate the first button of the Freehand toolbar under the Home tab. This way you can translate the selected object (Cube.stl) in the graphics window and locate it approximately over the propeller table.
10. Right-click the Cube in the Layout browser and then, in the menu Modify, choose the button “Set Position” to adjust its position. Set it to x=620, y=−122, z=338 mm w.r.t the World frame.
11. Right-click “Smart_Gripper_Servo_Fingers” and select “Disconnect library”. This operation allows us to disconnect the component from the library to edit it as desired.

12. Right-click “Smart_Gripper_Servo_Fingers” and select “Modify Mechanism”. This operation allows us to change the properties of the mechanism, e.g. the poses that will correspond to the gripper open and closed, respectively. Expand the window to visualize all the properties.

13. Click the button “Add” to add the desired poses corresponding to the cases when the gripper is open and closed. Set the “Pose Name” to “Gripper_open” and drag the slider to 25.00 mm, then click “OK”. Repeat this operation to set “Gripper_closed” position to 15.00 mm, since this corresponds to the cube width.

14. Then we need to add the Smart component itself. From the “Modeling” tab select the button “Smart Component”. This operation allows you to associate a component of the station with a complex behavior, e.g. gripper motion, objects moving on a conveyor.

15. In the “SmartComponent” window, click “Add component/Manipulators/PoseMover”: in this way you can enable the motion of the chosen manipulator joints to the desired pose.
16. Then, in the “Properties” window located on the left hand side of the view, we can set the properties that we want to associate to the desired smart component. In the specific case we want our gripper to move to the open position in 1 second. To do that, we need to set the “Mechanism” to “Smart_Gripper_Servo_Fingers”, the “pose” to “Gripper_open” and the “Duration” to 1. Click “Apply”.

17. Then we need to repeat this operation for the pose that corresponds to gripper closed. To do that, click again “Add component/Manipulators/PoseMover”. Then, set the “Mechanism” to “Smart_Gripper_Servo_Fingers”, the “pose” to “Gripper_closed” and the “Duration” to 1. Click “Apply”, then “Close”.

18. Up to now we have enabled the robot gripper to open and close to the predefined poses (see 13.) and we have associated these actions with a duration.

19. Open the Design browser of SmartComponent_1. Here we have a graphic summary of the properties associated with the two poses just designed.

20. Now we need to add some digital input that will be used as activation/deactivation signals for the open and close actions of the gripper. Let’s click on the button “Inputs” in the Design browser.

21. First, we want to create a digital signal that activates the gripper closure. To do that, we need to specify a signal type “Digital Input” that we call “DI_Close”, as shown in the following figure. Then, click “OK”.
22. Create another digital input that will allow to open the gripper. Once you have set the signal properties as illustrated in the following figure, click “OK”.

![Digital Input Configuration](image)

23. Now we need to associate the digital input signals just created to the corresponding poses. To do that, click on the browser “Signals and Connections” of the “SmartComponent_1” window. Click on “Add I/O Connections”.

![Signals and Connections](image)

24. Enable Close_gripper pose to be executed when the gripper closed input (source signal DI_close) is active, as follows:

![Close_gripper Connection Setup](image)

25. Click “OK” to confirm, then perform the corresponding operation for the Gripper_open pose.

![Gripper_open Connection Setup](image)

26. Now, if you click the “Design” browser again, you will visualize the components connected to the corresponding desired digital inputs.
27. Now we want to trigger an output from the system. Go to “Controller” tab, select the “Configuration” button and click “I/O system”.

28. Right-click “Signal”, select “New signal”.

29. The “Instance Editor” will pop-up to let you instantiate the new desired signal. Give it the name “GripperOpen” and select “digital output” type, modify the access level to “All”.
30. Do the corresponding operation to the "GripperClosed" digital output.

31. Now a restart of the controller is required. Under the “Controller” tab click “Restart” button and select “warmstart”.

32. If we go to the “Simulation” tab and we click “Station logic”. Select “Signals and Connections” browser.

33. Select “Add I/O Connection”.
34. Then set the properties illustrated in the following figure:

Click “OK” to confirm.

35. Then set the equivalent properties for the gripper close case, then click “OK”.

36. If we now go to the Design browser we will visualize the following scheme:

So the input signal “Gripper open” sent by the robot controller “Controller1” will trigger “DI_Open”, so it will generate the input signal for the gripper that will enable it to open. The controller signal “GripperClosed” will trigger the input signal “DI_Close” that will command the gripper to close.

37. We can check this behavior. Under the “Simulation” tab, click “I/O Simulator”.

38. This window will pop-up on the right-hand side of the RobotStudio IDE. Change the “Filter” property to “DigitalOutputs”. You will visualize the digital output “GripperClosed” and “GripperOpen” created previously.

If you click “GripperClosed” and “GripperOpen” the gripper will close and open, respectively.

39. Now we need to attach the cube to the gripper such that the gripper can grab the cube and move it to the desired position.

40. Let us go back to the “SmartComponent_1” browser and select the browser “Compose” and again select “Add Component/Actions” and select “Attacher”: this way you can associate the action that allows you to attach the desired object to the gripper when a specific situation is verified.

41. In the “Attacher properties” window we need to set the parent object, i.e the component that will take a part, as “Smart_Gripper_Servo_Fingers” and child object, i.e the component that must be attached, as “Cube”. Then click “Apply”.
42. Then we need to set the detacher action. To do that, go back to the “SmartComponent_1” browser and select the browser “Compose” and again select “Add Component/Actions” and select “Detacher”. This time the child object is the “Cube”. Let us set it, then click “Apply”.

43. Then go back to the browser “Signals and Connections”, click “Add I/O Connections”: this time we want to set that when the gripper closes we want to attach the object. To do that, let’s set the following properties:

44. Do the same for the detacher and click “OK”.

45. Hence, we set the following actions:
46. If we go to the “Design” browser we can see that when “DI_Close” is true, the “Gripper_closed” pose is executed and the object (Cube) is attached to the flange. Equivalently, when “DI_Open” becomes true, the “Gripper_open” pose is executed and the Cube is detached from the gripper.

47. Now, let us create the path that the robot must execute. Create an empty path (From the “Home” tab, select the button “Path/Empty Path”).

48. Modify the motion instruction template: change the velocity to “v500” and the zone to “fine”.

49. Select “Smart_Gripper_Servo_Finger” from the Layout browser. Right-click it and select “Rotate”. Select “Local” reference frame. Rotate it -90 degrees around z local axis. Click “Apply”, then “Close”.

50. If you want to make the gripper normal to the surface of the propeller table, click to the robot structure in the Layout browser, right-click and select “Mechanism Joint Jog”, set the orientation of the fifth joint to the desired value (for instance 90°).

51. Jog the robot manually in joint or linear mode to the desired pose, then from the Home tab, use the button “Teach instruction” to create the desired robot poses and the corresponding path. The robot must
pick the cube, and position it to the opposite side of the propeller table by overcoming the central cylinder of the propeller table.

Edit the first move instruction and change it to a MoveJ one.

52. Right-click "Path_10" and select "Move Along Path" to see the robot moving along the path just created.

53. Now we want to create instructions that will set the Digital output signals “Gripper_open” and “Gripper_closed” to true or false. To do that, right-click “Path_10” and select “Insert Action Instruction”.

54. Modify the Action instruction properties through the panel in the left-hand side of your RobotStudio IDE, as follows:

Click “Create”, then “Close”.

Thus, we have now created an instruction that will set the Digital Output (DO) “GripperClosed” to true (value 1).

Now repeat the operation to create an instruction that will set the Digital Output (DO) “GripperClosed” to false (value 0).

55. Repeat point 53. Changing the signal to “GripperOpen”.
56. Let us add a wait time equal to 1 second to let the gripper open and close before moving. To set a wait time, use the “Create Action Instruction” panel and set the property “Instruction Template” to WaitTime. Create two WaitTime instructions.

57. The motion and action instructions constituting Path_10 will be the following one:

Path_10
- MoveJ Target_10
- MoveL Target_20
- MoveL Target_30
- MoveL Target_40
- MoveL Target_50
- MoveL Target_60
- MoveL Target_70
- MoveL Target_80
- MoveL Target_90
- SetDO GripperClosed,1
- SetDO GripperClosed,0
- SetDO GripperOpen,1
- SetDO GripperOpen,0
- WaitTime 1
- WaitTime 1

58. Now we need to rearrange these motion and action instructions opportunistically to enable the robot to:

- go to the “pick” position (e.g. Target_40)
- close the Gripper (Set_DO GripperClosed,1)
- wait for 1 second to let the gripper close (WaitTime 1)
- move to the “place” position (e.g. Target_90)
- open the Gripper (Set_DO GripperClosed,0 and Set_DO GripperOpen,1)
- reset the DO GripperOpen to 0 (Set_DO GripperOpen,0)
- wait for 1 second to reset the system (WaitTime 1)
- insert a final motion instruction to make the robot move to a home position

This will correspond to:
59. From the Home tab press the button “Path”, create and Empty path and rename it as “main”.
60. Right-click “main” and select “Insert procedure call”.
61. Click “Synchronize/Synchronize to Rapid”. Select also “Path_10” and click “OK”.
62. Click the “Simulation” tab and press “Play” to run the simulation.
63. If you want to repeat the cycle, remember to move the cube back to position written at point 10.
64. If you want to compute the cycle-time associated with the execution of the overall pick and place, go to the “Simulation” tab, select the button “Stopwatch” and click “Add”. If you run again the simulation, the cycle-time will be displayed in the Stopwatch panel.